using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(?:\G(?!^);|Seats:\s*)\K\d+";
        string input = @"Seats: 11;12;
Name: qqqq;wwww;
Start: Прешов, АВ Košická 2725/2
End: Мукачево, АЗ Лавковская, 1б
Date: 2019-06-22
Time: 09:40 PM";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}