re = /(?:\G(?!^);|Seats:\s*)\K\d+/m
str = 'Seats: 11;12;
Name: qqqq;wwww;
Start: Прешов, АВ Košická 2725/2
End: Мукачево, АЗ Лавковская, 1б
Date: 2019-06-22
Time: 09:40 PM'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end