import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!^);|Seats:\\s*)\\K\\d+";
final String string = "Seats: 11;12;\n"
+ "Name: qqqq;wwww;\n"
+ "Start: Прешов, АВ Košická 2725/2\n"
+ "End: Мукачево, АЗ Лавковская, 1б\n"
+ "Date: 2019-06-22\n"
+ "Time: 09:40 PM";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}