using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'.*";
string substitution = @"";
string input = @"Hello Colm ""This is a test""\\""
""This is also an NL test""
'And this has an escaped quote don\'t in it ' Blue Boy
'euaoeu _
uaoeuaoeu
uaoeuaoeu
""This has a single quote ' but doesn\' end the quote as it started with double quotes"" 'comment
""""line spanning with escaped quote at the end of a line"""" 'comment
""""
""Foo Bar"" ""Another Value"" something else";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}