re = /'.*/m
str = 'Hello Colm "This is a test""\\\\"
"This is also an NL test"
\'And this has an escaped quote don\\\'t in it \' Blue Boy
\'euaoeu _
uaoeuaoeu
uaoeuaoeu
"This has a single quote \' but doesn\\\' end the quote as it started with double quotes" \'comment
"""line spanning with escaped quote at the end of a line""" \'comment
""""
"Foo Bar" "Another Value" something else'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result