import re
regex = re.compile(r"'.*", flags=re.MULTILINE)
test_str = ("Hello Colm \"This is a test\"\"\\\\\"\n"
"\"This is also an NL test\"\n\n"
"'And this has an escaped quote don\\'t in it ' Blue Boy\n\n"
"'euaoeu _\n"
"uaoeuaoeu\n"
"uaoeuaoeu\n\n"
"\"This has a single quote ' but doesn\\' end the quote as it started with double quotes\" 'comment\n\n"
"\"\"\"line spanning with escaped quote at the end of a line\"\"\" 'comment\n\n"
"\"\"\"\"\n\n"
"\"Foo Bar\" \"Another Value\" something else")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)