import Foundation
let pattern = #"'.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hello Colm "This is a test""\\"
"This is also an NL test"
'And this has an escaped quote don\'t in it ' Blue Boy
'euaoeu _
uaoeuaoeu
uaoeuaoeu
"This has a single quote ' but doesn\' end the quote as it started with double quotes" 'comment
"""line spanning with escaped quote at the end of a line""" 'comment
""""
"Foo Bar" "Another Value" something else
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)