// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)'.*").unwrap();
let string = "Hello Colm \"This is a test\"\"\\\\\"
\"This is also an NL test\"
'And this has an escaped quote don\\'t in it ' Blue Boy
'euaoeu _
uaoeuaoeu
uaoeuaoeu
\"This has a single quote ' but doesn\\' end the quote as it started with double quotes\" 'comment
\"\"\"line spanning with escaped quote at the end of a line\"\"\" 'comment
\"\"\"\"
\"Foo Bar\" \"Another Value\" something else";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}