# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\s+)?(\w+)\?.\s+\w+(?:\[\])?/this.$1 = item && "$1" in item ? item.$1 || null : null\n/gm;t' <<< "attributiAggiuntiviList?: List;
tipologiaAnagrafica?: number;
email?: string;
pec?: string;
sitoWeb?: string;
modalitaAcquisizione?: number;
dataAcquisizione?: Date;
referral?: string;
telefonos?: Telefon[];
preferenzaComunicazioneList?: List;
id?: string;
indirizzos?: Indirizzo[];
privacy?: Privacy[];
personaFisica?: PersonaFisica;
personaGiuridica?: string;
ente?: string;
uo?: string;
datiCliente?: DatiCliente;
datiFornitore?: DatiDipendente;
datiVendor?: DatiDipendente;
datiVettore?: DatiDipendente;
datiReferente?: DatiDipendente;
datiDipendente?: DatiDipendente;"