const regex = /(?:\s+)?(\w+)\?.\s+\w+(?:\[\])?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s+)?(\\w+)\\?.\\s+\\w+(?:\\[\\])?', 'gm')
const str = `attributiAggiuntiviList?: List;
tipologiaAnagrafica?: number;
email?: string;
pec?: string;
sitoWeb?: string;
modalitaAcquisizione?: number;
dataAcquisizione?: Date;
referral?: string;
telefonos?: Telefon[];
preferenzaComunicazioneList?: List;
id?: string;
indirizzos?: Indirizzo[];
privacy?: Privacy[];
personaFisica?: PersonaFisica;
personaGiuridica?: string;
ente?: string;
uo?: string;
datiCliente?: DatiCliente;
datiFornitore?: DatiDipendente;
datiVendor?: DatiDipendente;
datiVettore?: DatiDipendente;
datiReferente?: DatiDipendente;
datiDipendente?: DatiDipendente;`;
const subst = `this.$1 = item && "$1" in item ? item.$1 || null : null\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);