import Foundation
let pattern = #"(?:\s+)?(\w+)\?.\s+\w+(?:\[\])?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
attributiAggiuntiviList?: List;
tipologiaAnagrafica?: number;
email?: string;
pec?: string;
sitoWeb?: string;
modalitaAcquisizione?: number;
dataAcquisizione?: Date;
referral?: string;
telefonos?: Telefon[];
preferenzaComunicazioneList?: List;
id?: string;
indirizzos?: Indirizzo[];
privacy?: Privacy[];
personaFisica?: PersonaFisica;
personaGiuridica?: string;
ente?: string;
uo?: string;
datiCliente?: DatiCliente;
datiFornitore?: DatiDipendente;
datiVendor?: DatiDipendente;
datiVettore?: DatiDipendente;
datiReferente?: DatiDipendente;
datiDipendente?: DatiDipendente;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"this.$1 = item && "$1" in item ? item.$1 || null : null\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)