$re = '/(?:\s+)?(\w+)\?.\s+\w+(?:\[\])?/m';
$str = 'attributiAggiuntiviList?: List;
tipologiaAnagrafica?: number;
email?: string;
pec?: string;
sitoWeb?: string;
modalitaAcquisizione?: number;
dataAcquisizione?: Date;
referral?: string;
telefonos?: Telefon[];
preferenzaComunicazioneList?: List;
id?: string;
indirizzos?: Indirizzo[];
privacy?: Privacy[];
personaFisica?: PersonaFisica;
personaGiuridica?: string;
ente?: string;
uo?: string;
datiCliente?: DatiCliente;
datiFornitore?: DatiDipendente;
datiVendor?: DatiDipendente;
datiVettore?: DatiDipendente;
datiReferente?: DatiDipendente;
datiDipendente?: DatiDipendente;';
$subst = "this.$1 = item && \"$1\" in item ? item.$1 || null : null\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;