use strict;
my $str = 'attributiAggiuntiviList?: List;
tipologiaAnagrafica?: number;
email?: string;
pec?: string;
sitoWeb?: string;
modalitaAcquisizione?: number;
dataAcquisizione?: Date;
referral?: string;
telefonos?: Telefon[];
preferenzaComunicazioneList?: List;
id?: string;
indirizzos?: Indirizzo[];
privacy?: Privacy[];
personaFisica?: PersonaFisica;
personaGiuridica?: string;
ente?: string;
uo?: string;
datiCliente?: DatiCliente;
datiFornitore?: DatiDipendente;
datiVendor?: DatiDipendente;
datiVettore?: DatiDipendente;
datiReferente?: DatiDipendente;
datiDipendente?: DatiDipendente;';
my $regex = qr/(?:\s+)?(\w+)\?.\s+\w+(?:\[\])?/mp;
my $subst = 'this.$1 = item && "$1" in item ? item.$1 || null : null\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";