using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z]*)(?> |-)([0-9]{1,2})(?>, |-)([0-9]{2,4}) ([0-9]{1,2}:[0-9]{1,2}) (AM|PM)?";
string input = @"January 2, 2020 4:15 PM
January-14-20 12:44 PM
December-24-19 20:15 PM.
December-24-19 20:15 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}