re = /([a-zA-Z]*)(?> |-)([0-9]{1,2})(?>, |-)([0-9]{2,4}) ([0-9]{1,2}:[0-9]{1,2}) (AM|PM)?/m
str = 'January 2, 2020 4:15 PM
January-14-20 12:44 PM
December-24-19 20:15 PM.
December-24-19 20:15 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end