$re = '/([a-zA-Z]*)(?> |-)([0-9]{1,2})(?>, |-)([0-9]{2,4}) ([0-9]{1,2}:[0-9]{1,2}) (AM|PM)?/m';
$str = 'January 2, 2020 4:15 PM
January-14-20 12:44 PM
December-24-19 20:15 PM.
December-24-19 20:15 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);