package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<protocol>\w*)\:\/\/(?<username>[\w\-]*@)?(?<domain>(?:(?<thld>[\w\-]*)\.)?(?<sld>[\w\-]*)\.(?<tld>[a-zA-Z]*))(?:\:(?<port>\d*))?`)
var str = `Course at https://udemy.com/path/to/course
Test at http://user@sample.com/path
Something ftp://domain.com:80/any`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}