use strict;
my $str = 'Course at https://udemy.com/path/to/course
Test at http://user@sample.com/path
Something ftp://domain.com:80/any';
my $regex = qr/(?<protocol>\w*)\:\/\/(?<username>[\w\-]*@)?(?<domain>(?:(?<thld>[\w\-]*)\.)?(?<sld>[\w\-]*)\.(?<tld>[a-zA-Z]*))(?:\:(?<port>\d*))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}