re = /(?<protocol>\w*)\:\/\/(?<username>[\w\-]*@)?(?<domain>(?:(?<thld>[\w\-]*)\.)?(?<sld>[\w\-]*)\.(?<tld>[a-zA-Z]*))(?:\:(?<port>\d*))?/m
str = 'Course at https://udemy.com/path/to/course
Test at http://user@sample.com/path
Something ftp://domain.com:80/any'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end