# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d+)\.(.+?\..+?)\..*/$1_$2/;t' <<< "2.2.33.325"