using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+)\.(.+?\..+?)\..*";
string substitution = @"$1_$2";
string input = @"2.2.33.325";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}