// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\d+)\.(.+?\..+?)\..*").unwrap();
let string = "2.2.33.325";
let substitution = "$1_$2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}