const regex = /^(\d+)\.(.+?\..+?)\..*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d+)\\.(.+?\\..+?)\\..*', '')
const str = `2.2.33.325`;
const subst = `$1_$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);