$re = '/^(\d+)\.(.+?\..+?)\..*/';
$str = '2.2.33.325';
$subst = "$1_$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;