#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<\/?script[^>]*>"
Local $sString = "<script>" & @CRLF & _
"</script>" & @CRLF & _
"<script >" & @CRLF & _
"<script type="text/javascript">" & @CRLF & _
"<script type="text/javascript" >" & @CRLF & _
"<script 'wut'>" & @CRLF & _
"<Script>" & @CRLF & _
"<SCRIPT type="text/javascript">" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")