$re = '/<\/?script[^>]*>/i';
$str = '<script>
</script>
<script >
<script type="text/javascript">
<script type="text/javascript" >
<script \'wut\'>
<Script>
<SCRIPT type="text/javascript">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);