package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<\/?script[^>]*>`)
var str = `<script>
</script>
<script >
<script type="text/javascript">
<script type="text/javascript" >
<script 'wut'>
<Script>
<SCRIPT type="text/javascript">
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}