#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!(https:\/\/abc\.com|https:\/\/def\.com)).)*$"
Local $sString = "http://abc.com/somepage.html" & @CRLF & _
"http://abc.com/someotherpage.asp" & @CRLF & _
"https://abc.com/somepage.html" & @CRLF & _
"https://abc.com/someotherpage.asp" & @CRLF & _
"http://blef.com/boo.html" & @CRLF & _
"https://blef.com/bar.asp" & @CRLF & _
"http://blef.com" & @CRLF & _
"http://def.com/somepage.html" & @CRLF & _
"http://def.com/someotherpage.asp" & @CRLF & _
"https://def.com/somepage.html" & @CRLF & _
"https://def.com/someotherpage.asp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")