import Foundation
let pattern = #"^((?!(https:\/\/abc\.com|https:\/\/def\.com)).)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://abc.com/somepage.html
http://abc.com/someotherpage.asp
https://abc.com/somepage.html
https://abc.com/someotherpage.asp
http://blef.com/boo.html
https://blef.com/bar.asp
http://blef.com
http://def.com/somepage.html
http://def.com/someotherpage.asp
https://def.com/somepage.html
https://def.com/someotherpage.asp
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)