using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!(https:\/\/abc\.com|https:\/\/def\.com)).)*$";
string input = @"http://abc.com/somepage.html
http://abc.com/someotherpage.asp
https://abc.com/somepage.html
https://abc.com/someotherpage.asp
http://blef.com/boo.html
https://blef.com/bar.asp
http://blef.com
http://def.com/somepage.html
http://def.com/someotherpage.asp
https://def.com/somepage.html
https://def.com/someotherpage.asp";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}