$re = '/^((?!(https:\/\/abc\.com|https:\/\/def\.com)).)*$/m';
$str = 'http://abc.com/somepage.html
http://abc.com/someotherpage.asp
https://abc.com/somepage.html
https://abc.com/someotherpage.asp
http://blef.com/boo.html
https://blef.com/bar.asp
http://blef.com
http://def.com/somepage.html
http://def.com/someotherpage.asp
https://def.com/somepage.html
https://def.com/someotherpage.asp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);