use strict;
my $str = 'http://abc.com/somepage.html
http://abc.com/someotherpage.asp
https://abc.com/somepage.html
https://abc.com/someotherpage.asp
http://blef.com/boo.html
https://blef.com/bar.asp
http://blef.com
http://def.com/somepage.html
http://def.com/someotherpage.asp
https://def.com/somepage.html
https://def.com/someotherpage.asp';
my $regex = qr/^((?!(https:\/\/abc\.com|https:\/\/def\.com)).)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}