#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^a-zA-Z ]"
Local $sString = "ABC(D E+FGH?/IJK LMN~OP"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)