const regex = /[^a-zA-Z ]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z ]', 'g')
const str = `ABC(D E+FGH?/IJK LMN~OP`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);