use strict;
my $str = 'ABC(D E+FGH?/IJK LMN~OP';
my $regex = qr/[^a-zA-Z ]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";