import Foundation
let pattern = #"[^a-zA-Z ]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"ABC(D E+FGH?/IJK LMN~OP"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)