#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<(?:(?<closeTag>\/)?(?<tagName>[A-Za-z]+)(?<tagAttributes>(\s*(?:\w+)\s*=\s*(["|']).*?\5)*)\s*(?<selfClosingTag>\/)?>)"
Local $sString = "fafas<a href="test">fasfsafa</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")