using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?:(?<closeTag>\/)?(?<tagName>[A-Za-z]+)(?<tagAttributes>(\s*(?:\w+)\s*=\s*([""|']).*?\5)*)\s*(?<selfClosingTag>\/)?>)";
string input = @"fafas<a href=""test"">fasfsafa</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}