re = /<(?:(?<closeTag>\/)?(?<tagName>[A-Za-z]+)(?<tagAttributes>(\s*(?:\w+)\s*=\s*(["|']).*?\5)*)\s*(?<selfClosingTag>\/)?>)/m
str = 'fafas<a href="test">fasfsafa</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end