import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?:(?<closeTag>\\/)?(?<tagName>[A-Za-z]+)(?<tagAttributes>(\\s*(?:\\w+)\\s*=\\s*([\"|']).*?\\5)*)\\s*(?<selfClosingTag>\\/)?>)";
final String string = "fafas<a href=\"test\">fasfsafa</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}