package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`%(\w*?)%`)
var str = `<html>
<head>
<title>%getTitle%</title>
</head>
<body>
<div class='mainStream'>
%getLatestPostsByDate%
</div>
</body>
</html>`
var substitution = "<?php $1(); ?>"
fmt.Println(re.ReplaceAllString(str, substitution))
}