use strict;
my $str = '<html>
<head>
<title>%getTitle%</title>
</head>
<body>
<div class=\'mainStream\'>
%getLatestPostsByDate%
</div>
</body>
</html>';
my $regex = qr/%(\w*?)%/p;
my $subst = '<?php $1(); ?>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";