// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"%(\w*?)%").unwrap();
let string = "<html>
<head>
<title>%getTitle%</title>
</head>
<body>
<div class='mainStream'>
%getLatestPostsByDate%
</div>
</body>
</html>";
let substitution = "<?php $1(); ?>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}