$re = '/%(\w*?)%/';
$str = '<html>
<head>
<title>%getTitle%</title>
</head>
<body>
<div class=\'mainStream\'>
%getLatestPostsByDate%
</div>
</body>
</html>';
$subst = "<?php $1(); ?>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;