#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[?!.](?=[^?!.\s])"
Local $sString = "Hi!!Hello there! This is Robert. Happy New Year!Are you surprised?Im not."
Local $sSubst = "\g<0> "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)