import re
regex = re.compile(r"[?!.](?=[^?!.\s])", flags=re.MULTILINE)
test_str = "Hi!!Hello there! This is Robert. Happy New Year!Are you surprised?Im not."
subst = "\\g<0> "
result = regex.sub(subst, test_str)
if result:
print(result)