$re = '/[?!.](?=[^?!.\s])/m';
$str = 'Hi!!Hello there! This is Robert. Happy New Year!Are you surprised?Im not.';
$subst = "\g<0> ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;