re = /[?!.](?=[^?!.\s])/m
str = 'Hi!!Hello there! This is Robert. Happy New Year!Are you surprised?Im not.'
subst = '\\g<0> '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result