const regex = new RegExp('[?!.](?=[^?!.\\s])', 'gm')
const str = `Hi!!Hello there! This is Robert. Happy New Year!Are you surprised?Im not.`;
const subst = `\g<0> `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);