#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)(oh|msg)\s*(?=\{)(?:\{[^\{]*?\})"
Local $sString = "mSg" & @CRLF & _
"{ sda\r\n" & @CRLF & _
"sadsa\r\n" & @CRLF & _
"da\r\n};" & @CRLF & _
"//dfgdg" & @CRLF & _
"oh{fsdf}; jj" & @CRLF & _
"msg {ddd" & @CRLF & _
"msg" & @CRLF & _
"" & @CRLF & _
"msg { sda\r\n" & @CRLF & _
"sadsa\r\n" & @CRLF & _
"da\r\n};" & @CRLF & _
"//dfgdfg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")